$re = '/(?:^\[(?=[^][|]*(?:\|[^][|]*)*\])|(?!^)\G)([^][|]*)(?:[]|])/m';
$str = '[keyword1|keyword2|keyword3]
[keyword4|keyword5]
[keyword6]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);