package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\p{Ll})`)
var str = `arouzière`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}