#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d([\-\. ])?){7,15}"
Local $sString = "888-426-6840 215-861-6239" & @CRLF & _
"SPAIN Toll-Free: 900-8-01334" & @CRLF & _
"Caller Paid: 9-1-7878580" & @CRLF & _
"ITN Number: (*8) 2650 6840" & @CRLF & _
"Sandy Phillips 845-433-6476" & @CRLF & _
"USA Toll-Free: 888-426-6840" & @CRLF & _
"USA Caller Paid: 215-861-6239" & @CRLF & _
"Blackberry One Click +1-888-426-6840x6014774#" & @CRLF & _
"Call-In#: 888-426-6840 or 215-861-6239" & @CRLF & _
"USA/Mexico Toll-Free: 888-426-6840 " & @CRLF & _
"Hungary Toll-Free: 06-800-19-306" & @CRLF & _
"Canada Toll-Free: 888-426-6840 " & @CRLF & _
"UK Toll-Free: 0800-368-0638/02030596451 " & @CRLF & _
"USA Toll-Free: 888-426-6840 " & @CRLF & _
"USA Caller Paid: 215-861-6239 " & @CRLF & _
"United Kingdom Caller Paid 0-20-30596451 " & @CRLF & _
"United Kingdom Toll-Free 0800-368-0638"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")