using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|[a-zA-z0-9]{9}";
string substitution = @"";
string input = @"|c001177ffSave Code =|r |cff00AA00A|cff00AA00G|cff00AA00Q|cffff69b4g|r |cff00AA00R|cff40e0d09|cffffff00$|cffffff00#|r |cff40e0d04|cffff69b4f|cff00AA00R";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}