$re = '/(R>|skip>)(.*?)</s';
$str = '<BR>
<IMG skip>Юзер1<BR>
<BR>
Юзер2<BR>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);