const regex = /^(.*[\/])[^\/]*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*[\\\/])[^\\\/]*$', '')
const str = `http://tjktv.ercdn.net/tjktv.m3u8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}