$re = '/skipped\s+(\d+)/mi';
$str = 'Executed 29 of 31 (3 FAILED) (skipped 2) (0.283 secs / 0.08 secs)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);