package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`spot2(.*)`)
var str = `www.cargo-partner.com/spot2/cp/*`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}