$re = '/.*?([0-9]+)$/m';
$str = 'foo 12
12 foo 123
foo 12 foo 1234
f1o2o 12345
foo 12 123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);