$re = '/(?:\brules\s+\{|(?!^)\G)\s+([\w-]+)/';
$str = 'regulations { qux def } standards none rules { abc-123 456-defghi wxyz_678 } security { enabled }';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);