$re = '/^-?[0-9]*e\^-?[0-9]*x$/m';
$str = '-3e^x
100e^-x
e^-2x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);