$re = '/-?\d+(\.\d+)?/m';
$str = '2010
-1000
10.2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);