$re = '/^.*stuff382689,.*?\d.+[^,]$/m';
$str = '/category/stuff382689,25090,,1
/category/stuff382689,25090,,2
/category/stuff382689,25090';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);