re = /^\/csr_and_sustainability_information\/(?!.*iframe)/m
str = '/csr_and_sustainability_information/blahblah/blah/blah-iframe-asd
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah-iframe-blah/blah/blah-asdhaud/iframe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end