const regex = new RegExp('<a[\\s\\S]*? \\bhref="(mailto:(.*?))"[\\s\\S]*?>(.*?)</a>', 'gm')
const str = `<p>Lorem ipsum dolor sit amet, <a href="#coucou">consectetur </a> dipiscing elit. <a href="mailto:fakeEmail@gmail.com">Email Tag Content 1</a>.Sic enim censent, oportunitatis esse beate vivere. Omnia contraria, quos etiam insanos esse vultis. Virtutis, magnitudinis animi, patientiae, fortitudinis fomentis dolor mitigari solet. <a href="mailto:email@address.uk">Quid</a>, cum fictas fabulas, e quibus utilitas nulla elici potest, cum voluptate legimus? Duo Reges: <a href="mailto:tt@tt.com" class="asdkfj">constructio</a> interrete. Vos autem cum perspicuis dubia debeatis illustrare, dubiis perspicua conamini tollere. Quid ad utilitatem <a class="t" href="mailto:aaa@uuu.ik">tantae</a> pecuniae? Quod non subducta utilitatis ratione effici solet, sed ipsum a se oritur et sua sponte nascitur.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}