$re = '/^(?!12)[0-9]{6}$/m';
$str = '123456
113456
213456
523456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);