import Foundation
let pattern = #"((\/|\||\[)+(\s)*[12]{1}(T|°|º|ºT|°T)*)|([^\|\s]*([\d]+T\s|[\d]+T|[\d]+ºT\s)+(\||\[|\/)+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
2ºT | ⏱ 48 min: cruzamento de Raphael Veiga e Felipe Melo cabeceia para fora. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 47 min: amarelo para Raphael Veiga. \n\n#PALxCHA | 3x1\n#AvantiPalestra
2ºT | ⏱ 45 min: mais 4 minutos de acréscimos. \n\n#PALxCHA | 3x1\n#AvantiPalestra
2ºT | ⏱ 42 min: cruzamento preciso de Luan do meio-campo e Rony cabeceia para fora. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 28 min: substituições 🔄\n\n🔼 Entram: L. Esteves e F. Melo \n🔽 Saem: Wesley e G. Scarpa
2ºT | ⏱ 26 min: amarelo para Wesley. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
Com a saída de Luiz Adriano, Willian passa a ser o capitão do time em campo ©️\n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão https://t.co/PbpAHZH68u
2ºT | ⏱ 25 min: substituição 🔄\n\n🔼 Entra: Willian \n🔽 Sai: Luiz Adriano \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 21 min: após bate e rebate, Zé Rafael fica com a bola e manda por cima do gol. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 9 min: Palmeiras 3x1 Chapecoense. \n\n#AvantiPalestra #PALxCHA\n#JuntosNoBrasileirão
2ºT | ⏱ 3 min: jogada ensaiada em cobrança de escanteio: Gustavo Scarpa cruza na entrada da área para 1ºT | ⏱ 8 min: Veiga cruza na área, Rony desvia de cabeça e manda por cima do gol.\n\n#PALxCRB
|45' | 2T | +6. Jogo vai aos 51. \n\nABC Futebol Clube 3x0 Chapecoense\n \n#VamosChape
43' | 2T | Entra Felipe Santana no lugar de Matheus Ribeiro. \n\nABC Futebol Clube 3x0 Chapecoense\n
45' | 2T | +4. Jogo vai aos 49. \n\nPalmeiras 3x1 Chapecoense\n \n#VamosChape #OrgulhoDeSerChape
35' | 2T | Muda a Chape:\n\nEntram ➡️ Bruno Silva e Geuvânio\nSaem ⬅️Fabinho e Anselmo Ramon
32' | 2T | Adversário cobra falta, mas a bola desvia na barreira e sai em escanteio. \n\nPalmeiras 3x1
24' | 2T | QUAAAAAAAASEEEEEEEEEE! \n\nRavanelli manda no segundo pau e Anselmo Ramon finaliza de
13' | 2T | Ravanelli tocou para Matheus Ribeiro, que invadiu a área a finalizou na rede, mas pelo lado
7' | 2T | Falta para a Chapecoense na meia-lua da grande área. \n\nPalmeiras 3x0 Chapecoense\n
7' | 1T | Gol do Palmeiras. \n\nPalmeiras 1x0 Chapecoense\n \n#VamosChape #OrgulhoDeSerChape
2' | 1T | UHHHHHHHHHHHHHHHHHHH!\n\nFabinho fica cara a cara com Jailson e finaliza, obrigando grande
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)