package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<time>\d{4}-\d{2}-\d{2}\s*\d{2}:\d{2}:\d{2})\s*(?P<user>[^\s]*)\s*(?P<url>[^\s]+)\s*(?|(?P<log_msg>.*)\s*(?P<stack_trace>Stack trace:.*)|(?P<log_msg>.*))`)
var str = `2017-01-25 08:34:40 admin http://cms-site.tajawal.local:92/en/almosafer/com/block/footer/ Error: Uncaught Error: Call to undefined function ProcessWire\getAlmosaferFooterLinks() in /var/www/cms-site/site/templates/alm-footer.php:9 Stack trace: #0 /var/www/cms-site/wire/core/TemplateFile.php(268): require() #1 [internal function]: ProcessWire\TemplateFile->___render() #2 /var/www/cms-site/wire/core/Wire.php(374): call_user_func_array(Array, Array) #3 /var/www/cms-site/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod('___render', Array) #4 /var/www/cms-site/wire/core/Wire.php(399): ProcessWire\WireHooks->runHooks(Object(ProcessWire\TemplateFile), 'render', Array) #5 /var/www/cms-site/wire/modules/PageRender.module(514): ProcessWire\Wire->__call('render', Array) #6 [internal function]: ProcessWire\PageRender->___renderPage(Object(ProcessWire\HookEvent)) #7 /var/www/cms-site/wire/core/Wire.php(374): call_user_func_array(Array, Array) #8 /var/www/cms-site/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod('___renderPage', Array) #9 /var/www/cms-site/wire/core/Wire.php(399): ProcessWire\Wir (line 9 of /var/www/cms-site/site/templates/alm-footer.php)
2017-01-25 08:35:01 admin http://cms-site.tajawal.local:92/en/almosafer/com/block/footer/ Error: Uncaught Error: Call to undefined function ProcessWire\getAlmosaferFooterLinks() in /var/www/cms-site/site/templates/alm-footer.php:9 Stack trace: #0 /var/www/cms-site/wire/core/TemplateFile.php(268): require() #1 [internal function]: ProcessWire\TemplateFile->___render() #2 /var/www/cms-site/wire/core/Wire.php(374): call_user_func_array(Array, Array) #3 /var/www/cms-site/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod('___render', Array) #4 /var/www/cms-site/wire/core/Wire.php(399): ProcessWire\WireHooks->runHooks(Object(ProcessWire\TemplateFile), 'render', Array) #5 /var/www/cms-site/wire/modules/PageRender.module(514): ProcessWire\Wire->__call('render', Array) #6 [internal function]: ProcessWire\PageRender->___renderPage(Object(ProcessWire\HookEvent)) #7 /var/www/cms-site/wire/core/Wire.php(374): call_user_func_array(Array, Array) #8 /var/www/cms-site/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod('___renderPage', Array) #9 /var/www/cms-site/wire/core/Wire.php(399): ProcessWire\Wir (line 9 of /var/www/cms-site/site/templates/alm-footer.php)
2017-01-25 08:35:01 admin http://cms-site.tajawal.local:92/en/almosafer/com/block/footer/ Error: Uncaught Error: Call to undefined function ProcessWire\getAlmosaferFooterLinks() in /var/www/cms-site/site/templates/alm-footer.php:9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}