$re = '/^[A-Za-z0-9](?:[A-Za-z0-9 -]){1,8}$/';
$str = 'abcdeefg-';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);