$re = '/^[_0-9]{2}-[_0-9]{3}$/m';
$str = '4_-__';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);