$re = '/([\w<>/]+|\.)/';
$str = 'This is a <span>sentence</span>.
This last sentence has <span>four words</span>.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);