$re = '/(?<=\s)#([A-Za-z0-9_]+)/';
$str = 'SHOULD WORK: #test
SHOULDN\'T WORK:#test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);