const regex = new RegExp('catalog/products/(?![^/]*\\d{4}\\.)([^/]+)\\.aspx$', 'gm')
const str = `catalog/products/gl1800-airbag.aspx
catalog/products/cab2.aspx
catalog/products/gl1800-airbag-2007.aspx
catalog/products/cab2-2007.aspx
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}