$re = '/(?:^|[^2])(2)(?!2)/';
$str = '1232163122631261112312';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);