re = /^[\w-\+\.\_]+(\.[\w-\+\.\_]+)*@[\w-\+\.\_]+(\.[\w\+\.\_]+)*(\.[A-Za-z]{2,})$/
str = '^[\\\\w-\\\\+\\\\.\\\\_]+(\\\\.[\\\\w-\\\\+\\\\.\\\\_]+)*@[\\\\w-\\\\+\\\\.\\\\_]+(\\\\.[\\\\w\\\\+\\\\.\\\\_]+)*(\\\\.[A-Za-z]{2,})$
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end