re = /[^\/,\s\?#]+?\.[^\/,\s]+?(?=\/|\s|$|\?|#)/
str = 'https://www.google.com/hello/hi.php, http://youtube.com
http://test.net#jump or http://google.com?q=test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end