package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_@#][a-zA-Z0-9@$#_]*$`)
var str = `abc
1ab
_3c
#ab
$abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}