use strict;
my $str = 'JHMCU26809C211501 - good
JHMGD18508S219366 - good
JHMCU268091111111 - bad
12345678901234567 - good
ASD1111111ASD2313 - bad
ASDIIIIIIIASDASD2 - bad
IIIIIIIADS1EE2345 - bad
';
my $regex = qr/^(?!.*(\w)\1{3,}).+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}