$re = '/^(?!.*(.)\1{2})[A-Z]{1}[a-zA-Z ]{3,29}$/m';
$str = 'qwertyqwertyqwerty';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);