re = /([a-zA-Z0-9._-]+@[a-zA-Z0-9._-]+\.[a-zA-Z0-9_-]+)/m
str = 'John Doe, JohnDoe@stack.io phone:00336598745'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end