package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\d+$(*SKIP)(*FAIL)|^[a-z\d]+$`)
var str = `test123
1234
testtest
1ab2c3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}