import re
regex = re.compile(r"(([0-9]+((.|,)[0-9])*)\s\btablespoons?\b)", flags=re.MULTILINE)
test_str = "9 Super 7 Carburetors RPM Torque (lb-ft) Horsepower 3,300 375.0 235.6 3,400 367.4 237.8 3,500 368.0 245.2 3,600 366.1 250.9 3,7000 360.3 295.0 4,400 362.9 304.0 4,500 367.0 314.5 4,600 364.0 318.8 4,700 363.1 324.9 4,800 361.0 329.9 4,900 352.5 328.9 5,000 350.0 333.2 5,100 353.1 mhfgdjytgtrd 5 tablespoons"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")