$re = '/[\x{0600}-\x{06FF}]/';
$str = '
به زبان بی زبانی هم عادت کرده ایم؛ برنامه نویسی که دیگر چیزی نیست
آ
ی
ب
پ
خ
ژ
گ
ک
ك
ي
ء
۰
۱
۲
۳
۴
۵
۶
۷
۸
۹
،
؛
a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);