using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(\d{10})$";
string substitution = @"$1";
string input = @"1445238051199999999999999";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}