import re
regex = re.compile(r"(?<=^|\bfoobar\b)(?!foobar\b)(.*?)(?=\bfoobar\b|$)", flags=re.DOTALL)
test_str = ("notfoobarfoobarnot\n"
"this should be highlighted, and\n"
"same with this. but any sentence\n"
"that has the word\n"
"foobar\n"
"shouldnt be, and same for any regular\n"
"sentence with foobar <-- like that\n"
"foobar beginning a sentence should invalidate\n"
"the entire sentence, same with at the end foobar\n"
"only foobar, and nothing else of the sentence\n"
"more words here more irrelevant stuff to highlight\n"
"and nothing of the key word\n"
"what about multiple foobar on the same foobar line?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")