$re = '/([^:]+):(.*)/m';
$str = 'test1:_|TEST:-TEST.|
test2:_|TEST:-TEST.|
test3:_|TEST:-TEST.|';
$subst = "$1;$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;