$re = '/<a\s+(?:[^>]*?\s+)?href=(["\'])(.*?)\1/';
$str = '<a href="test"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);