# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^Test case ([A-Za-z]+)\s+Current Parameters:(?:[^:]+:.*?$)*)+.*?(Test \2 (PASS|FAIL))"
test_str = ("Test case AAA\n"
"Current Parameters:\n"
" Some unique param : 1\n"
" Some unique param : 2\n"
" Some unique param : 3\n"
" Some unique param : 4\n"
"*A line of rubbish*\n"
"*Another line of rubbish*\n"
"*Yet another line of rubbish*\n"
"*More and more rubbish*\n"
"Test AAA PASS\n"
"Test case BBB\n"
"Current Parameters:\n"
" Some unique param : A\n"
" Some unique param : B\n"
" Some unique param : C\n"
" Some unique param : D\n"
"*A line of rubbish*\n"
"*Another line of rubbish*\n"
"*Yet another line of rubbish*\n"
"*More and more rubbish*\n"
"Test BBB PASS")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.