$re = '/^((?!proposed_).)*((project|task)_details)/mi';
$str = 'project_details
proposed_project_details
task_details
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);