$re = '/(([a-z])(?!\g{-1})[a-z])\1{2}/m';
$str = 'bhbhbhbhbh blaytytytyt
dddddddddddddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);