$re = '/([\w]+)\{([\w]+)\:([0-9.]+)\}/iu';
$str = 'в{в:30948.70}нормальных{нормальный:110.70}условиях{условие:364.20}данное{данный:0.00}соединение{соединение:56.60}находится{находиться:339.00}в{в:30948.70}газообразном{газообразный:1.70}состоянии{состояние:290.10}не{не:17692.40}имеет{иметь:895.40}цвета{цвет:176.40}и{и:35302.69}запаха{запах:92.80}однако{однако:516.29}обладает{обладать:103.80}кисловатым{кисловатый:0.80}вкусом{вкус:77.50}растворяется{растворяться:7.10}в{в:30948.70}воде{вода:480.00}образуя{образовывать:35.29}при{при:1538.30}этом{это:5477.60}угольную{угольный:13.80}карбонатную{карбонатный:1.80}кислоту{кислота:22.90}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);