package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\(([^\)]*)\)\(([\d]*)\)\(([^\)]*)\)\(([^\)]*)\)`)
var str = `(name)(123)(percent)(who)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}