$re = '/(?:(?<=\s)|^)(?:[a-z]|\d+)/i';
$str = 'Regal Crown Center Stadium 14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);