package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)^[ \-0-9a-zA-ZäöüÄÖÜß.]+?\s+(\d+(\s?[a-zA-Z])?)\s*(?:$|\(|[A-Z]{2})`)
    var str = `Straßenname 1
Straßenname 123
Straßen-name 1
Straßen name 1
Straßenname 1a
Straßenname 1 a
Straßenname 1 A
Straßenname 123/a
Straßenname 123-a
Straßenname
Straßenname a
Straßenname 1ab`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}