re = /<li>(?:.(?!<\/li>))+Code:(?:.*?)<\/li>/i
str = '<ul><li><span>some words here.</span></li><li><span>other words here.</span></li><li><span>Code: 55555.</span></li></ul>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end