re = /((?:https?\:\/\/|www\.)(?:[-a-z0-9]+\.)*[-a-z0-9]+.*)/i
str = 'https://google.com
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end