import Foundation
let pattern = ##"^[a-zA-Z0-9!#$%&\'*+\\\=?^_`{|}~-]+(?:\.[a-zA-Z0-9!#$%&\'*+\\\=?^_`{|}~-]+)*@(?:[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?\.)+[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"nossair@additioapp.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}