$re = '/^https?:\/\/www\.(youtube.com|youtu.be).*(v=)([a-zA-Z0-9_-]+)$/m';
$str = 'http://www.youtube.com/watch?v=PnqC
http://www.youtube.com/watch?v=
http://www.youtube.com/watch?v=PnqCS4Lvy5E';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);