#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im): ([^\s]+)(?:[^\[]+)?\[([^:/]+[:/][^\s]+)(?:\s*l.[\d]+)?\] - ([a-f0-9]{24})?(?: - )?(.+)$"
Local $sString = "Nov 21 15:55:59 dasyure uwsgi.rtemail: INFO 18695 - [rtemail_base:process_m5e l.940] - 546f527f4b295f0ecb9a78b8 - ruid=ff6d4e50-dd2d-40c5-978c-0d8726674e4a m5e=66ae77250da162719d907a8d71bcceec from=mongodb ms=1 status=continue" & @CRLF & _
"Nov 21 15:55:59 dasyure uwsgi.rtemail: INFO mule:18695 - [rtemail:process_in_exclusion l.355] - 546f527f4b295f0ecb9a78b8 - tagid=6545389 in_exclusion=false status=continue" & @CRLF & _
"Nov 21 15:56:09 dasyure uwsgi.rtemail: DEBUG 18695 - [idents_message:__init__ l.22] - 546f527f4b295f0ecb9a78b8 - init_json json={'ruid': UUID('ff6d4e50-dd2d-40c5-978c-0d8726674e4a'), 'url': u'http://www.rueducommerce.fr/Ordinateurs/Ordinateur-Portable/Ordinateur-Portable-Grand-Public/APPLE/4920409-MacBook-Air-13-MD760F-B.htm#moid:MO-76BD5M31349632', 'ip': 127000000001, 'exclu': False, 'params': {'idproduit': [u'RSYS:30:4920409']}, 'message': {'google_cver': None, 'accept_cookies': True, 'ident': '6545389_ff6d4e50-dd2d-40c5-978c-0d8726674e4a_66ae77250da162719d907a8d71bcceec', 'ggruid': 3658, 'r1': (False, UUID('ff6d4e50-dd2d-40c5-978c-0d8726674e4a'), False), 'r3': (False, UUID('ff6d4e50-dd2d-40c5-978c-0d8726674e4a'), False), 'eulerian_uid': None, 'sync': [], 'tagid': 6545389, 'utcnow': datetime.datetime(2014, 11, 21, 14, 55, 59, tzinfo=<bson.tz_util.FixedOffset object at 0x7f3edfa707d0>), 'new_cookie': False, 'adnxs_uid': None, 'action': 3, 'google_gid': None, 'ck1add': {}, 'now': datetime.datetime(2014, 11, 21, 15, 55, 59, 329577), 'cpu': {'stats': False, 'pixel': False, 'syncJS': False, 'syncJarM5e': False}}, '_id': ObjectId('546f527f4b295f0ecb9a78b8'), 'ua': u'Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36'}" & @CRLF & _
"Nov 21 15:56:09 dasyure uwsgi.rtemail: INFO 18695 - [rtemail_base_client:process_is_expired l.90] - 546f527f4b295f0ecb9a78b8 - expired=false status=continue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")