$re = '/(\b[a-z].+(?=\s|$))(?=.*\1)/i';
$str = 'fire alarm/fire/g.i. joe/g.i. jane';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);